杰拉斯的博客

[ACM_ZJUT_1058]Humble Numbers

杰拉斯 杰拉斯 | 时间:2012-04-10, Tue | 5,973 views
编程算法 

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8472 Accepted Submission(s): 3684

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input


1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output


The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source

HDU1058

今天课多,连晚上也有,刚好看到水题一道,拿来凑数,可纠结的是竟然Wrong Answer!后来才发现原来是我英文水平有待提高,不仅是11,12,13后面是加th的,任何以11,12,13结尾的数字后面都是加th,而非st,nd跟rd。

思路跟[ACM_ZJUT_1089]Ugly Numbers基本一模一样,动态规划,不多讲。

代码如下(时间很晚了,明天有早课,所以没怎么优化,可能难看了点):

#include<stdio.h>
#include<vector>
#include<cmath>
using namespace std;
//_hdu_1058
int main(){
	int n = 5842, m;
	vector<int> v;
	int x2 = 0, x3 = 0, x5 = 0, x7 = 0;
	char s[4][3] = {"th", "st", "nd", "rd"};
	v.push_back(1);
	while(--n){
		int r2 = v[x2] * 2;
		int r3 = v[x3] * 3;
		int r5 = v[x5] * 5;
		int r7 = v[x7] * 7;
		m = min(r2, r3);
		m = min(m, r5);
		m = min(m, r7);
		v.push_back(m);
		if(r2 == m)
			++x2;
		if(r3 == m)
			++x3;
		if(r5 == m)
			++x5;
		if(r7 == m)
			++x7;
	}
	while(scanf("%d", &n) && n){
		printf("The %d%s humble number is %d.\n", n, (n % 10 < 4 && n % 100 != 11 && n % 100 != 12 && n % 100 != 13)?s[n % 10]:"th", v[n - 1]);
	}
	return 0;
}

如需转载请注明出处:杰拉斯的博客

相关文章

当前暂无评论 »