杰拉斯的博客

[ACM_HDU_1297]Children’s Queue

杰拉斯 杰拉斯 | 时间:2012-04-01, Sun | 21,077 views
编程算法 

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5660 Accepted Submission(s): 1755

Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

Sample Input


1
2
3

Sample Output


1
2
4

Source

HDU1297

思路如下:

一个长度n的队列可以看成一个n - 1的队列再追加的1个小孩,这个小孩只可能是:

a.男孩,任何n - 1的合法队列追加1个男孩必然是合法的,情况数为f[n - 1];

b.女孩,在前n - 1的以女孩为末尾的队列后追加1位女孩也是合法的,我们可以转化为n - 2的队列中追加2位女孩;

一种情况是在n - 2的合法队列中追加2位女孩,情况数为f[n - 2];

但我们注意到本题的难点,可能前n - 2位以女孩为末尾的不合法队列(即单纯以1位女孩结尾),也可以追加2位女孩成为合法队列,而这种n - 2不合法队列必然是由n - 4合法队列+1男孩+1女孩的结构,即情况数为f[n - 4]。

若感觉本题较难,可先查看文章:[ACM_HDU_2045]LELE的RPG难题,思路与本题类似,但较为简单。

得出递推公式如下:

f[n] = f[n - 1] + f[n - 2] + f[n - 4]

还有需要注意的是本题中可能得出极大的数字,如当n为1000时,结果为:

12748494904808148294446671041721884239818005733501580815621713101333980596197474744336199742452912998225235910891798221541303838395943300189729514282623665199754795574309980870253213466656184865681666106508878970120168283707307150239748782319037

这种超大数完全不是C++提供的数值类型能够储存的,因此我们可以使用数组来模拟超大数运算,详情请看[ACM_ZJUT_1382]计算N!(数组模拟超大数运算)

代码如下:

#include<stdio.h>
int main(){
	int n;
	int f[1001][101] = {0};
	f[0][1] = 1;
	f[1][1] = 1;
	f[2][1] = 2;
	f[3][1] = 4;
	for(int i = 4; i < 1001; ++i){
		for(int j = 1; j < 101; ++j){
			f[i][j] += f[i - 1][j] + f[i - 2][j] + f[i - 4][j];	//数组的每一位相加
			f[i][j + 1] += f[i][j] / 10000;	//超过4位的部分保存至数组下一位中
			f[i][j] %= 10000;	//每位数组只保存其中4位
		}
	}
	while(scanf("%d", &n) != EOF){
		int k = 100;
		while(!f[n][k--]);	//排除前面为空的数组
		printf("%d", f[n][k + 1]);	//输出结果的前四位
		for(; k > 0; --k){
			printf("%04d", f[n][k]);	//输出其余的所有四位数字,若数字小于四位,则前面用0填充
		}
		printf("\n");
	}
	return 0;
}

如需转载请注明出处:杰拉斯的博客

相关文章

5 条评论 »

  1. housansan housansan

    在前n - 1的以女孩为末尾的队列后追加1位女孩也是合法的,我们可以转化为n - 2的队列中追加2位女孩;

    为什么要追加换成2位。不换时就是 f[n - 3]。
    为什么我这么理解不行??

    1. 不换时就是f[n - 3]?怎么理解?
      n - 3 的话那还需要追加3个才可以达到 n,这3个要怎么安排呢?

  2. 青鸢不死 青鸢不死

    大数计算为什么定义k=100

    1. 因为前面定义的数组:
      int f1001;
      所以从100开始往后查。

  3. 不会撒谎的乌索普 不会撒谎的乌索普

    没看懂。