杰拉斯的博客

[ACM_HDU_3177]Crixalis's Equipment

杰拉斯 杰拉斯 | 时间:2012-07-25, Wed | 25,627 views
编程算法 

Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1350 Accepted Submission(s): 543

Description

Crixalis's EquipmentCrixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

Input

The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0

Output

For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".

Sample Input

2

20 3
10 20
3 10
1 7

10 2
1 10
2 11

Sample Output

Yes
No

Source

HDU3177

这道题采用的是贪心的思路,值得注意的是排序的方法,这道题无论是根据Ai或者Bi来排序得到的结果都是WA,Ai排序就不必说了,如这组测试数据:

20 2
1 1
10 20

先搬占用空间小的,即(1, 1) → (10, 20),结果是No,而正确答案是Yes。

如这组测试数据:

20 2
5 17
1 16

先搬所需空间大的,即(5, 17) → (1, 16),结果是No,而正确答案是Yes。

我们设第一件物品的占用空间和搬运所需空间分别为A1和B1,第二件为A2和B2,则:

先搬第一件物品所需最大临时空间为A1 + B2,先搬第二件物品所需的最大临时空间为A2 + B1,那么很明显应该选择所需最大临时空间较小的方案。

代码如下:

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
struct S{
	int a, b;
};
bool cmp(const S &s1, const S &s2){
	if(s1.a + s2.b == s2.a + s1.b)
		return s1.b < s2.b;
	return s1.a + s2.b < s2.a + s1.b;
	//return s1.b - s1.a > s2.b - s2.a;	也可
}
int main(){
	S s;
	vector<S> vec;
	int t, v, n, flag;
	scanf("%d", &t);
	while(t--){
		flag = 0;
		scanf("%d%d", &v, &n);
		while(n--){
			scanf("%d%d", &s.a, &s.b);
			vec.push_back(s);
		}
		sort(vec.begin(), vec.end(), cmp);
		for(vector<S>::iterator it = vec.begin(); it != vec.end(); ++it){
			if(v >= (*it).b && v >= (*it).a){
				v -= (*it).a;
			}else{
				flag = 1;
				break;
			}
		}
		if(flag)
			printf("No\n");
		else
			printf("Yes\n");
		vec.clear();
	}
	return 0;
}

2013年5月4日20时温习重写代码如下:

#include<stdio.h>
#include<vector>
#include<algorithm>

using namespace std;

struct s{
	int a, b;
	s(int a, int b){
		this->a = a;
		this->b = b;
	}
};

bool cmp(s s1, s s2){
	if(s1.a + s2.b == s2.a + s1.b){
		return s1.b < s2.b;
	}
	return s1.a + s2.b < s2.a + s1.b;
}

int main(){
	int t, v, n, a, b;
	scanf("%d", &t);
	while(t--){
		vector<s> vec;
		bool flag = true;
		scanf("%d%d", &v, &n);
		while(n--){
			scanf("%d%d", &a, &b);
			vec.push_back(s(a, b));
		}
		sort(vec.begin(), vec.end(), cmp);
		for(vector<s>::iterator it = vec.begin(); it != vec.end(); ++it){
			if(v < (*it).a || v < (*it).b){
				flag = false;
				break;
			}
			v -= (*it).a;
		}
		if(flag){
			printf("Yes\n");
		}else{
			printf("No\n");
		}
	}
	return 0;
}

如需转载请注明出处:杰拉斯的博客

相关文章

2 条评论 »

  1. 非常喜欢这篇文章。。。。欢迎回访

  2. seancheer seancheer

    感谢楼主的分享,讲的很好。