杰拉斯的博客

[ACM_POJ_1163]动态规划入门练习(一)The Triangle

杰拉斯 杰拉斯 | 时间:2012-04-02, Mon | 21,693 views
编程算法 

The Triangle

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28092 Accepted: 16504

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

POJ1163

这道题如果用枚举法(暴力思想),在数塔层数稍大的情况下(如31),则需要列举出的路径条数将是一个非常庞大的数目(2^30= 1024^3 > 10^9=10亿)。

因此我们可以从下往上推,相邻的两个数中找较大的与上层相加,得出的结果相邻的两个数中再找较大的与上层相加,以此类推。

代码如下:

#include<stdio.h>
int main(){
	int n, i, j;
	scanf("%d", &n);
	int **a = new int*[n];
	for(i = 0; i < n; ++i){
		a[i] = new int[i + 1];
		for(j = 0; j <= i; ++j){
			scanf("%d", &a[i][j]);
		}
	}
	for(i = n - 2; i >=0; --i){
		for(j = 0; j <= i; ++j){
			a[i][j] += a[i + 1][j] > a[i + 1][j + 1] ? a[i + 1][j] : a[i + 1][j + 1];
		}
	}
	printf("%d", a[0][0]);
	return 0;
}

如需转载请注明出处:杰拉斯的博客

相关文章

2 条评论 »

  1. 我是一只小小鱼 我是一只小小鱼

    不到20行的代码,0s,不超200k内存!佩服!LZ,好想知道你是怎么写出这题代码?

    1. 几年前写的了,如今好久没碰算法了T_T。。